Tài liệu hạn chế xem trước, để xem đầy đủ mời bạn chọn Tải xuống
1
/ 23 trang
THÔNG TIN TÀI LIỆU
Thông tin cơ bản
Định dạng
Số trang
23
Dung lượng
193,36 KB
Nội dung
Laboratory Exercises—
Solutions
Overview
This module contains solutions to the exercises that are part of the Basic IP
Multicast course.
There is no solution part to the exercise Applications and IP Multicast since all
the necessary information is provided in the exercise itself.
The exercise Initial Lab Setup includes initial router configurations.
The exercises IGMP Concepts and PIM Dense Mode and PIM Sparse Mode
Concepts include answers to Review Questions.
The exercise Simple IP Multicast Deployment includes answers to Review
Questions and a sample router configuration.
This module includes the following sections:
■ B: Inital Lab Setup
■ B-1: Verification of the Initial Router Configuration
■ C-1: IGMP Concepts and Working
■ C-2: PIM Dense Mode Protocol Basics
■ C-3: PIM Dense Mode Protocol Mechanics
■ D-1: PIM Sparse Mode Protocol Basics
■ D-2: PIM Sparse Mode Protocol Mechanics
■ E-1: PIM Sparse-dense Mode and Manual RP Configuration
2 Laboratory Exercises—Solutions Copyright 2000, Cisco Systems, Inc.
B: Initial Lab Setup
Lab Solution
The initial configurations of routers acting as sources and receivers are provided
as well as configurations of workgroup routers.
Note Minor variations in configurations may appear with respect to the platforms used.
The hostnames are referred to in their abbreviated form without the workgroup
number.
Source
version 12.0
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname Source
!
enable secret 5 $1$I9Vf$lbWnExLuOAxLq1Y8Ckm0E/
enable password cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0/0
ip address 172.16.8.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
ip default-gateway 172.16.8.1
ip classless
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
end
R1
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R1
!
enable secret 5 $1$d6qE$5QHDfRbqbmPFjAnhd8SwN1
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host Source 172.16.8.2
ip host Receiver2 172.16.2.2
ip host Receiver1 172.16.5.2
ip host R6 192.168.100.16
Copyright 2000, Cisco Systems, Inc. Laboratory Exercises—Solutions 3
ip host R5 192.168.100.15
ip host R4 192.168.100.14
ip host R3 192.168.100.13
ip host R2 192.168.100.12
ip host R1 192.168.100.11
!
interface Loopback0
ip address 192.168.100.11 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
description R1-R5
bandwidth 64
ip address 172.16.6.1 255.255.255.0
frame-relay interface-dlci 591
!
interface Serial0/0.2 point-to-point
description R1-R2
bandwidth 64
ip address 172.16.1.1 255.255.255.0
frame-relay interface-dlci 291
!
router ospf 1
no log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.11 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
end
R2
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R2
!
enable secret 5 $1$eR0m$.Df45QXDydOrc3croKiWv.
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host R1 192.168.100.11
ip host R2 192.168.100.12
ip host R3 192.168.100.13
ip host R4 192.168.100.14
ip host R5 192.168.100.15
ip host R6 192.168.100.16
ip host Receiver1 172.16.5.2
ip host Receiver2 172.16.2.2
ip host Source 172.16.8.2
!
interface Loopback0
ip address 192.168.100.12 255.255.255.255
!
interface Loopback1
ip address 172.16.2.2 255.255.255.0
!
4 Laboratory Exercises—Solutions Copyright 2000, Cisco Systems, Inc.
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
description R2-R3
bandwidth 64
ip address 172.16.3.1 255.255.255.0
frame-relay interface-dlci 392
!
interface Serial0/0.2 point-to-point
description R2-R1
bandwidth 64
ip address 172.16.1.2 255.255.255.0
ip igmp version 2
frame-relay interface-dlci 291
!
router ospf 1
no log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.12 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
end
R3
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R3
!
enable secret 5 $1$QQEE$l9YQFlWpSFjZ9uLmulHXX0
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host R1 192.168.100.11
ip host R2 192.168.100.12
ip host R3 192.168.100.13
ip host R4 192.168.100.14
ip host R5 192.168.100.15
ip host R6 192.168.100.16
ip host Receiver1 172.16.5.2
ip host Receiver2 172.16.2.2
ip host Source 172.16.8.2
!
interface Loopback0
ip address 192.168.100.13 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.9.1 255.255.255.0
no ip mroute-cache
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
description R3-R2
Copyright 2000, Cisco Systems, Inc. Laboratory Exercises—Solutions 5
bandwidth 64
ip address 172.16.3.2 255.255.255.0
frame-relay interface-dlci 392
!
interface Serial0/0.2 point-to-point
description R3-R6
bandwidth 64
ip address 172.16.10.2 255.255.255.0
frame-relay interface-dlci 693
!
router ospf 1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.13 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
end
R4
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R4
!
enable secret 5 $1$aRlA$hyJTDYvNPkXeUFohxP32M0
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host R1 192.168.100.11
ip host R2 192.168.100.12
ip host R3 192.168.100.13
ip host R4 192.168.100.14
ip host R5 192.168.100.15
ip host R6 192.168.100.16
ip host Receiver1 172.16.5.2
ip host Receiver2 172.16.2.2
ip host Source 172.16.8.2
!
interface Loopback0
ip address 192.168.100.14 255.255.255.255
!
interface Loopback1
ip address 172.16.5.2 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.5.1 255.255.255.0
no ip mroute-cache
half-duplex
speed 10
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
description R4-R6
bandwidth 64
ip address 172.16.4.2 255.255.255.0
frame-relay interface-dlci 694
6 Laboratory Exercises—Solutions Copyright 2000, Cisco Systems, Inc.
!
router ospf 1
no log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.14 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
end
R5
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R5
!
enable secret 5 $1$m8J1$e5JCJIS9Ck0EtW625YLa60
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host R1 192.168.100.11
ip host R2 192.168.100.12
ip host R3 192.168.100.13
ip host R4 192.168.100.14
ip host R5 192.168.100.15
ip host R6 192.168.100.16
ip host Receiver1 172.16.5.2
ip host Receiver2 172.16.2.2
ip host Source 172.16.8.2
!
interface Loopback0
ip address 192.168.100.15 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.7.1 255.255.255.0
no ip mroute-cache
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
description R5-R1
bandwidth 64
ip address 172.16.6.2 255.255.255.0
frame-relay interface-dlci 591
!
router ospf 1
no log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.15 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
Copyright 2000, Cisco Systems, Inc. Laboratory Exercises—Solutions 7
password cisco
logging synchronous
login
!
end
R6
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R6
!
enable secret 5 $1$m8rn$cTnVe6g5i1a2xQRJEsQBd.
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host R1 192.168.100.11
ip host R2 192.168.100.12
ip host R3 192.168.100.13
ip host R4 192.168.100.14
ip host R5 192.168.100.15
ip host R6 192.168.100.16
ip host Receiver1 172.16.5.2
ip host Receiver2 172.16.2.2
ip host Source 172.16.8.2
!
interface Loopback0
ip address 192.168.100.16 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.7.2 255.255.255.0
no ip mroute-cache
!
interface Ethernet0/1
ip address 172.16.8.1 255.255.255.0
no ip mroute-cache
!
interface Serial1/0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial1/0.1 point-to-point
description R6-R4
bandwidth 64
ip address 172.16.4.1 255.255.255.0
frame-relay interface-dlci 694
!
interface Serial1/0.2 point-to-point
description R6-R3
bandwidth 64
ip address 172.16.10.1 255.255.255.0
frame-relay interface-dlci 693
!
router ospf 1
no log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 16
network 192.168.100.16 0.0.0.0 area 16
!
ip classless
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
logging synchronous
login
!
8 Laboratory Exercises—Solutions Copyright 2000, Cisco Systems, Inc.
end
Copyright 2000, Cisco Systems, Inc. Laboratory Exercises—Solutions 9
B-1: Verification of the Initial Router Configuration
Task 1: Verification of the Initial Router Configuration
The tables with IP addresses of the individual interfaces on the workgroup routers
are provided below. x is the workgroup number and y is 15 + x.
Router Interface Address Subnet Mask
WGxR1 Loopback 0 192.168.100.x1 255.255.255.255
Loopback 0 192.168.100.x2 255.255.255.255WGxR2
Loopback 1 172.y.2.2 255.255.255.0
WGxR3 Loopback 0 192.168.100.x3 255.255.255.255
Loopback 0 192.168.100.x4 255.255.255.255WGxR4
Loopback 1 172.y.5.2 255.255.255.0
WGxR5 Loopback 0 192.168.100.x5 255.255.255.255
WGxR6 Loopback 0 192.168.100.x6 255.255.255.255
Step 1: Loopback IP address assignment
Router Interface Address Subnet Mask
WGxR3 Ethernet 0/0 172.y.9.1 255.255.255.0
WGxR4 Ethernet 0/0 172.y.9.2 255.255.255.0
WGxR5 Ethernet 0/0 172.y.7.1 255.255.255.0
Ethernet 0/0 172.y.7.2 255.255.255.0WGxR6
Ethernet 0/1 172.y.8.1 255.255.255.0
Step 2: LAN IP address assignment
Router Interface Address Subnet Mask
Serial 0/0.1 172.y.6.1 255.255.255.0WGxR1
Serial 0/1.2 172.y.1.1 255.255.255.0
Serial 0/0.1 172.y.3.1 255.255.255.0WGxR2
Serial 0/1.2 172.y.1.2 255.255.255.0
Serial 0/0.1 172.y.10.1 255.255.255.0WGxR3
Serial 0/1.2 172.y.3.2 255.255.255.0
WGxR4 Serial 0/0.1 172.y.4.2 255.255.255.0
WGxR5 Serial 0/0.1 172.y.6.2 255.255.255.0
Serial 1/0.1 172.y.4.1 255.255.255.0WGxR6
Serial 1/1.2 172.y.10.1 255.255.255.0
Step 3: WAN IP address assignment
Router Interface Address Subnet Mask
WgxSource Ethernet0/0 172.y.8.2 255.255.255.0
Step 4: Source IP address assignment
10 Laboratory Exercises—Solutions Copyright 2000, Cisco Systems, Inc.
C-1: IGMP Concepts and Working
Answers to Review Questions (after Step 4)
■ What is the IP address of the IGMP Querier on each of your routers' LAN's?
The IGMP Querier is elected as the router, which has the lowest IP
address on that segment.
■ Explain the IGMP Querier election process and the function of the IGMP
QuerierinanIGMPcontext.
On a shared segment all routers initially send out an IGMP Query
Message. The router with the lowest IP address on that segment is
elected to be the Querier.
Note There is no formal IGMP Query Router election in IGMPv1.
The IGMP Querier is responsible for sending periodic IGMP Queries on
a shared segment on which it was elected as an IGMP Querier.
■ What is the purpose of the Designated Router listed in show ip igmp
interface command?
The Designated router (DR) has no meaning in the PIM Dense mode.
The only exception is if IGMP v1 is used simultaneously. In this case
the DR also acts as an IGMP Querier since there is no formal
mechanism for election in IGMP v1.
The role of the Designated Router in the PIM Sparse mode is essential.
The DR is responsible for sending Joins towards the Rendezvous-Point
(RP), and for switching-over to the SPT. If the DR is on the source
segment the DR is also responsible for sending Registers towards the
RP.
■ Explain the procedure that follows the reception of an IGMP Leave message
on the segment.
After an IGMPv2 Querying router receives an IGMP Leave message for
a specific group and if there are no IGMPv1 hosts on that segment, the
router responds with IGMP Group Specific Query for that group The
router prunes off the traffic for this group if the Group Specific Query is
not responded within the interval.
If there are IGMPv1 hosts on the segment, the router simply waits for
the group to time out.,
■ What could be a reason that you see 224.2.127.254 and 239.255.255.255
groups as groups joined by the router itself?
The router joins to groups 224.2.127.254 and 239.255.255.255 if it is
configured to listen to sdr announcements with ip sdr listen command.
224.2.127.254 is a classic multicast IP address and 239.255.255.255 is a
scoped multicast IP address used by the sdr application.
[...]... 2000, Cisco Systems, Inc Laboratory Exercises Solutions 13 I If the source is active, the Assert in PIM Dense mode happens every three minutes Why? The Assert in the PIM Dense mode occurs every three minutes because in that time the prune state expires, the interface goes into a forwarding state and the multicast packet triggers the Assert procedure again 14 Laboratory Exercises Solutions Copyright ... is misconfigured I How would you fix this problem? A removal of the static groups usually solves the problem Ensuring that there are no loops in the network will prevent RPF Check failures 12 Laboratory Exercises Solutions Copyright 2000, Cisco Systems, Inc C-3: PIM Dense Mode Protocol Mechanics Task 1: PIM Dense Mode Pruning and Grafting Answers to Review Questions (after Step 3) I How long did it... an RPF neighbor address? – Copyright 2000, Cisco Systems, Inc What is the incoming interface for the (S, G) entry (172.y.8.2, 224.1.2.3) on each router? What are the flags for this entry? Laboratory Exercises Solutions 11 – What interfaces are in the outgoing interface list (OIL) for this entry on each router and what are their statuses? Router Incoming interface RPF neighbor address Flags OIL interfaces... answers from Step 2 After joining the Receiver2 to group 224.1.2.3 a change only on R2 is noted C and L flags appears and the interface Loopback1 is added to Copyright 2000, Cisco Systems, Inc Laboratory Exercises Solutions 15 the OIL in a (*, G) state entry since there is now a directly connected receiver Answers to Review Questions (after Step 4) I Complete the following table: – What is the incoming... towards the RPF and in a case of (S, G) towards the source I What does the F flag on router R6 mean? The F flag on R6 means that R6 is the first hop router for a directly connected source 16 Laboratory Exercises Solutions Copyright 2000, Cisco Systems, Inc Task 4: Switching to the Shortest Path Tree Answers to Review Questions (after Step 6) Complete the following table: I – What is the incoming... downstream router (R4 in this case) switched to the SPT and the Prune message was sent towards the RP to prune off the traffic flowing down the shared tree Copyright 2000, Cisco Systems, Inc Laboratory Exercises Solutions 17 I What is the meaning of the J flag in the entries in router R4? The J flag in (S, G) entry on R4 means that the router, due to the sptthreshold being crossed, switched to SPT I... still being received I Did the router join the SPT or not? Explain the reasons R2 did not switch to SPT although the (S, G) entry already existed The SPT Threshold is still set to infinity 18 Laboratory Exercises Solutions Copyright 2000, Cisco Systems, Inc D-2: PIM Sparse Mode Protocol Mechanics Task 1: PIM Sparse Mode Shared Tree Formation—Receivers Answers to Review Questions (after Step 1) I What... The intermediate routers between the first-hop router and the RP create (S, G) and (*, G) entries when they receive (S, G) Join or (S, G) Prune messages Copyright 2000, Cisco Systems, Inc Laboratory Exercises Solutions 19 Task 3: Switching to the Shortest-Path Tree Answers to Review Questions (after Step 4) I What happens in the last-hop router when the traffic exceeds the STP Threshold? When traffic... react? Router R1, acting as the RP, reacts by adding the interface into the OIL list of the (*, G) entry and initiates a (S, G) Join towards the source to clear the previously pruned tree 20 Laboratory Exercises Solutions Copyright 2000, Cisco Systems, Inc D-1: PIM Sparse-dense Mode and Manual RP Configuration Task 4: Monitoring and debugging PIM Sparse-dense Answers to Review Questions (after Step... respective RP and on the routers between the RP and the first hop router due to periodic Data-header Register messages sent periodically by the first-hop router Copyright 2000, Cisco Systems, Inc Laboratory Exercises Solutions 21 Answers to Review Questions (after Step 7) I Why do you now see (S, G) and (*, G) entries for all three groups in almost every router? (S, G) and (*, G) entries are seen in almost . synchronous
login
!
8 Laboratory Exercises Solutions Copyright 2000, Cisco Systems, Inc.
end
Copyright 2000, Cisco Systems, Inc. Laboratory Exercises Solutions. Laboratory Exercises—
Solutions
Overview
This module contains solutions to the exercises that are part of the