Tài liệu hạn chế xem trước, để xem đầy đủ mời bạn chọn Tải xuống
1
/ 87 trang
THÔNG TIN TÀI LIỆU
Thông tin cơ bản
Định dạng
Số trang
87
Dung lượng
2,1 MB
Nội dung
Chapter 8
The Routing Table: A Closer Look
2
For further information
This presentation is an
overview of what is
covered in the
curriculum/book.
For further explanation
and details, please read
the chapter/curriculum.
Book:
Routing Protocols
and Concepts
By Rick Graziani and
Allan Johnson
ISBN: 1-58713-206-0
ISBN-13: 978-58713-
206-3
3
Topics
The Routing Table Structure
Topology
Routing Table Entries
Level 1 Routes
Parent and Child Routes:
Classful Networks
Parent and Child Routes:
Classless Networks
Routing Table Lookup Process
Steps in the Route Table
Lookup Process
Longest Match: Level 1
Routes
Longest Match: Level 2
Routes
Routing Behavior
Classful and Classless
Routing Behavior
Classful Routing Behavior: no
ip classless
Classless Routing Behavior: ip
classless
The Routing Table Structure
5
The Routing Table Structure
The structure of the routing table might seem obvious.
Help you verify and troubleshoot routing issues because you will
understand the routing table lookup process.
You will know exactly what the Cisco IOS software does when it
searches for a route.
Router# show ip route
172.16.0.0/24 is subnetted, 4 subnets
S 172.16.4.0 is directly connected, Serial0/0/1
R 172.16.1.0 [120/1] via 172.16.2.1, 00:00:08, Serial0/0/0
C 172.16.2.0 is directly connected, Serial0/0/0
C 172.16.3.0 is directly connected, FastEthernet0/0
10.0.0.0/16 is subnetted, 1 subnets
S 10.1.0.0 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Serial0/0/1
S 192.168.100.0/24 is directly connected, Serial0/0/1
6
Notice that R3 also has a 172.16.4.0/24 subnet that is disconnected, or
discontiguous, from the 172.16.0.0 network that R1 and R2 share.
The effects of this discontiguous subnet are examined later in this chapter
when you look at the route lookup process.
Topology
7
Topology: Interface Configurations for R1 and R3
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface Serial0/0/0
R1(config-if)# ip address 172.16.2.1 255.255.255.0
R1(config-if)# clock rate 64000
R1(config-if)# no shutdown
R3(config)# interface FastEthernet0/0
R3(config-if)# ip address 172.16.4.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface Serial0/0/1
R3(config-if)# ip address 192.168.1.2 255.255.255.0
R3(config-if)# no shutdown
8
Sample Routing Table Entries
Route entries from the following sources:
Directly connected networks
Static routes
Dynamic routing protocols
The source of the route does not affect the structure of the
routing table
Router# show ip route
172.16.0.0/24 is subnetted, 4 subnets
S 172.16.4.0 is directly connected, Serial0/0/1
R 172.16.1.0 [120/1] via 172.16.2.1, 00:00:08, Serial0/0/0
C 172.16.2.0 is directly connected, Serial0/0/0
C 172.16.3.0 is directly connected, FastEthernet0/0
10.0.0.0/16 is subnetted, 1 subnets
S 10.1.0.0 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Serial0/0/1
S 192.168.100.0/24 is directly connected, Serial0/0/1
9
Sample Routing Table Entries
The routing table hierarchy in Cisco IOS software was originally
implemented with the classful routing scheme.
Although the routing table incorporates both classful and
classless addressing, the overall structure is still built around
this classful scheme.
Router# show ip route
172.16.0.0/24 is subnetted, 4 subnets
S 172.16.4.0 is directly connected, Serial0/0/1
R 172.16.1.0 [120/1] via 172.16.2.1, 00:00:08, Serial0/0/0
C 172.16.2.0 is directly connected, Serial0/0/0
C 172.16.3.0 is directly connected, FastEthernet0/0
10.0.0.0/16 is subnetted, 1 subnets
S 10.1.0.0 is directly connected, Serial0/0/1
C 192.168.1.0/24 is directly connected, Serial0/0/1
S 192.168.100.0/24 is directly connected, Serial0/0/1
10
Level 1 Routes
Serial 0/0/1 interface for R2 is configured with the 192.168.1.1/24 address
As soon as no shutdown is entered, the output from debug ip routing
shows that this route has been added to the routing table.
R2# debug ip routing
IP routing debugging is on
R2# conf t
R2(config)# interface serial 0/0/1
R2(config-if)# ip address 192.168.1.1 255.255.255.0
R2(config-if)# clock rate 64000
R2(config-if)# no shutdown
R2(config-if)#
00:11:06: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
R2(config-if)#
RT: add 192.168.1.0/24 via 0.0.0.0, connected metric [0/0]
RT: interface Serial0/0/1 added to routing table
R2(config-if)# end
R2# undebug all
All possible debugging has been turned off
[...]... specific route entry 28 Routing Table Lookup Process Routing Table Lookup Process IP Packet Routing Table Find “best match” When a router receives a packet on one of its interfaces The routing table lookup process compares the destination IP address of the incoming packet with the entries in the routing table The best match between the packet’s destination IP address and the route in the routing table is...Level 1 Routes RT: add 192.1 68. 1.0/24 via 0.0.0.0, connected metric [0/0] RT: interface Serial0/0/1 added to routing table R2(config-if)# end R2# show ip route C 192.1 68. 1.0/24 is directly connected, Serial0/0/1 The routing table is actually a hierarchical structure that is used to speed up the lookup process when locating routes and forwarding packets Within this structure,... 172.16.0.0 17 Parent and Child Routes: Classful Networks Level 1 Parent Route Level 2 Child Route A level 2 route is a route that is a subnet of a classful network address Like a level 1 route, the source of a level 2 route can be a : directly connected network static route dynamic routing protocol Note: This is the case even if a classless routing protocol is the source of the subnet route 18 Parent route:... child route and that route is removed, the level 1 parent route is automatically deleted A level 1 parent route exists only when there is at least one level 2 child route 23 Parent and Child Routes: Classless Networks For this discussion, we switch briefly to the RouterX topology 24 Parent and Child Routes: Classless Networks RouterX# show ip route C C C 172.16.0.0/16 is 172.16.1.4/30 172.16.1 .8/ 30 172.16.3.0/24... 192.1 68. 1.0/24 is directly connected, Serial0/0/1 A level 1 route is a route with a subnet mask equal to or less than the classful mask of the network address 192.1 68. 1.0/24 is a level 1 network route because the subnet mask is equal to the network’s classful mask /24 is the classful mask for Class C networks, such as the 192.1 68. 1.0 network 12 Level 1 Routes We will be using this chart throughout this chapter. .. 192.1 68. 1.0/24 is directly connected, Serial0/0/1 Neither R1 nor R2 has a route to 172.16.4.0 Also, R3 does not have routes to subnets 172.16.1.0/24, 172.16.2.0/24, or 172.16.3.0/24 32 The Route Lookup Process Routing Table Step 1 The router examines level 1 routes, including network routes and supernet routes, for the best match with the destination address of the IP packet 33 The Route Lookup Process Routing. .. is subnetted, 2 subnets C 172.16.2.0 is directly connected, Serial0/0/0 C 172.16.3.0 is directly connected, FastEthernet0/0 C 192.1 68. 1.0/24 is directly connected, Serial0/0/1 The routing table shows two child routes for the same 172.16.0.0/24 parent route 172.16.2.0 and 172.16.3.0 are members both members of the 172.16.0.0/16 classful network Because both child routes have the same subnet mask, the... connected, FastEthernet0/0 Child Route C 192.1 68. 1.0/24 is directly connected, Serial0/0/1 Another type of level 1 network route, a parent route When the 172.16.3.0 subnet was added to the routing table, Another route, 172.16.0.0 also added First entry: no next-hop IP address or exit interface information This route is known as a level 1 parent route 16 Parent and Child Routes: Classful Networks R2# show... mask, and the parent displayed their common subnet mask 26 Parent route: 172.16.0.0: The parent route, the classful network address associated with all child routes /16: The classful subnet mask of the parent route variably subnetted: States that the child routes are variably subnetted and that there are multiple masks for this classful network 3 subnets, 2 masks: Indicates the number of subnets and. .. FastEthernet0/0 Child Route C 192.1 68. 1.0/24 is directly connected, Serial0/0/1 A parent route is a heading: Indicates the presence of level 2 routes, also known as child routes A level 1 parent route is automatically created any time a subnet is added to the routing table A parent route is created whenever a route with a mask greater than the classful mask is entered into the routing table The subnet 172.16.3.0 . explanation
and details, please read
the chapter/ curriculum.
Book:
Routing Protocols
and Concepts
By Rick Graziani and
Allan Johnson
ISBN: 1- 587 13-206-0
. 1- 587 13-206-0
ISBN-13: 9 78- 587 13-
206-3
3
Topics
The Routing Table Structure
Topology
Routing Table Entries
Level 1 Routes
Parent and Child Routes: