CHƯƠNG 3 : KẾT QUẢ MÔ PHỎNG
3.1. Mô phỏng VLAN:
3.1.1. Các bước mô phỏng và code kèm theo:
B1: Sử dụng phần mềm Cisco Packet Tracer để thiết kế ra mạng như sau :
B2 : Cấu hình địa chị IP cho các máy tính
- PC0 , PC3 , PC6 : 192.168.10.xx
- PC1, PC4, PC7 : 192.168.20.xx
- PC2, PC5,PC8 : 192.168.30.xx B3: Cấu hình cho switch 1:
- Thực hiện cấu hình password, đặt tên:
- Switch#config t
- Switch(config)#hostname sw1
- Đặt password enable là 123:
- sw1(config)#enable password 123
- Đặt password enable được mã hoá là: class
- sw1(config)#enable secret class
- Đặt password cho việc truy cập vào switch bằng cổng console:
- sw1(config)#line console 0
- sw1(config-line)#login
- sw1(config-line)#password 1234
- sw1(config-line)#exit
- Đặt password cho việc truy cập vào switch bằng line vty
- sw1(config)#line vty 0 4
- sw1(config-line)#login
- sw1(config-line)#password 1234
- sw1(config-line)#exit
- sw1(config)#do wr
- - Thực hiện cấu hình vlan trên switch1 như sau:
- sw1(config)#vlan 10 - sw1(config-vlan)#name engineer - sw1(config-vlan)#exit - sw1(config)#vlan 20 - sw1(config-vlan)#name business - sw1(config-vlan)#exit - sw1(config)#vlan 30 - sw1(config-vlan)#name HR - sw1(config-vlan)#exit
- Gắn các interface 0/1, f0/2, f0/3 là chế độ access và vào các vlan tương ứng:
- sw1(config)#int f0/1
- sw1(config-if)#switchport mode access
- sw1(config-if)#switchport access vlan 10
- sw1(config-if)#exit
- sw1(config)#int f0/1
- sw1(config-if)#exit
- sw1(config)#int f0/2
- sw1(config-if)#switchport mode access
- sw1(config-if)#switchport access vlan 20
- sw1(config-if)#exit
- sw1(config)#int f0/3
- sw1(config-if)#switchport mode access
- sw1(config-if)#switchport access vlan 30
- Thiết lập interface f0/4 là chế độ trunk, cho phép tất cả các vlan truy cập vào.
- sw1(config)#int f0/4
- sw1(config-if)#switchport mode trunk
- sw1(config-if)#
- sw1(config-if)#switchport trunk all vlan all
- sw1(config-if)#exit
- sw1(config)#do write
B4: cấu hình cho SW2: đối với sw2 thì f0/4 và f0/5 là trunk; các f0/1,
- f0/2, f0/3 tương tự như cấu hình sw1.
- Switch>en - Switch#config t - Switch(config)#hostname sw2 - sw2(config)#vlan 10 - sw2(config-vlan)#name engineer - sw2(config-vlan)#exit - sw2(config)#vlan 20 - sw2(config-vlan)#name business - sw2(config-vlan)#exit
- sw2(config-if)#exit
- sw2(config)#int f0/2
- sw2(config-if)#switchport mode access
- sw2(config-if)#switchport access vlan 20
- sw2(config-if)#exit
- sw2(config)#int f0/3
- sw2(config-if)#switchport mode access
- sw2(config-if)#switchport access vlan 30
- sw2(config-if)#exit
- sw2(config)#int f0/4
- sw2(config-if)#switchport mode trunk
- sw2(config-if)#switchport trunk all vlan all
- sw2(config-if)#exit
- sw2(config)#int f0/5
- sw2(config-if)#switchport mode trunk
- sw2(config-if)#switchport trunk all vlan all
- sw2(config-if)#exit
- sw2(config)#do write
B5: Cấu hình cho switch3: f0/4 là trunk, các port cịn lại tương tự
- Switch>en - Switch#config t - Switch(config)#hostname sw3 - sw3(config)#vlan 10 - sw3(config-vlan)#name engineer - sw3(config-vlan)#exit
- sw3(config)#vlan 20 - sw3(config-vlan)#name business - sw3(config-vlan)#exit - sw3(config)#vlan 30 - sw3(config-vlan)#name HR - sw3(config-vlan)#exit - sw3(config)#int f0/1
- sw3(config-if)#switchport mode access
- sw3(config-if)#switchport access vlan 10
- sw3(config-if)#exit
- sw3(config)#int f0/2
- sw3(config-if)#switchport mode access
- sw3(config-if)#switchport access vlan 20
- sw3(config-if)#exit
- sw3(config)#int f0/3
- sw3(config-if)#switchport mode access
- sw3(config-if)#switchport access vlan 30
- sw3(config-if)#exit
B6: Thực hiện lệnh ping từ PC0 đến PC3, PC6:
Như ta thấy , chúng cùng 1 VLAN vì thế chúng có thể kết nối với nhau Thử ping từ PC0 đến PC1 :
-
Ta thấy tuy được nối dây nhưng chúng lại không liên kết được với nhau vì khơng cùng 1 VLAN.